🔍 CVE-2025-12705

7.2
CVSS Score
HIGH
2025-12-09
2026-10-07 20:10
✅ 완료

🇰🇷 한글 설명

WordPress용 Social Reviews & Recommendations 플러그인의 'trim_text' 함수 내 여러 파라미터에서 입력값 검증 및 출력 이스케이프 처리가 미흡하여 저장형 XSS 취약점이 발생합니다. 이를 통해 인증되지 않은 공격자가 임의의 웹 스크립트를 삽입할 수 있으며, 사용자가 해당 페이지에 접속할 때 스크립트가 실행됩니다.

💡 쉬운 설명

게시판이나 리뷰란에 악성 코드를 몰래 심어두는 공격입니다. 사용자가 해당 리뷰를 읽는 순간, 공격자가 의도한 나쁜 동작이 사용자의 브라우저에서 자동으로 실행될 수 있습니다.

🇺🇸 원문 (English)

The Social Reviews & Recommendations plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in the 'trim_text' function in all versions up to, and including, 2.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.5.

📍 영향받는 시스템

Social Reviews & Recommendations plugin (WordPress) version 2.5 및 그 이하 모든 버전

⚔️ 공격 벡터

인증되지 않은 공격자가 'trim_text' 함수의 취약한 파라미터에 악성 스크립트를 삽입하여 서버에 저장

🛡️ 대응 방법

플러그인을 최신 버전으로 업데이트하거나, 보안 패치가 적용된 버전 2.5 이상을 사용하십시오.

🔧 검증 코드

출력된 결과에서 해당 플러그인의 버전이 2.5 이하인지 확인하십시오.

Shell / Script
wp-cli plugin list --allow-root | grep -E 'social-reviews-recommendations'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

💻 영향받는 소프트웨어

WordPress