🔍 CVE-2025-13535

6.4
CVSS Score
MEDIUM
2026-04-01
2026-10-07 09:10
✅ 완료

🇰🇷 한글 설명

WordPress의 King Addons for Elementor 플러그인 5.1.38 이하 버전에서 다수의 DOM 기반 저장형 XSS 취약점이 발견되었습니다. 입력값 검증 및 출력 이스케이프 미흡으로 인해 기여자(Contributor) 이상의 권한을 가진 공격자가 악성 스크립트를 삽입할 수 있습니다. 이 스크립트는 페이지 방문자나 관리자가 편집기에서 페이지를 미리 볼 때 실행될 수 있습니다.

💡 쉬운 설명

플러그인의 설정값에 악성 코드를 숨겨두면, 해당 페이지를 보는 사람의 브라우저에서 해킹 코드가 실행될 수 있는 문제입니다. 권한이 있는 사용자가 위젯 설정을 조작하여 관리자의 정보를 훔치거나 페이지를 변조할 수 있습니다.

🇺🇸 원문 (English)

The King Addons for Elementor plugin for WordPress is vulnerable to multiple Contributor+ DOM-Based Stored Cross-Site Scripting vulnerabilities in all versions up to, and including, 51.1.38. This is due to insufficient input sanitization and output escaping across multiple widgets and features. The plugin uses esc_attr() and esc_url() within JavaScript inline event handlers (onclick attributes), which allows HTML entities to be decoded by the DOM, enabling attackers to break out of the JavaScript context. Additionally, several JavaScript files use unsafe DOM manipulation methods (template literals, .html(), and window.location.href with unvalidated URLs) with user-controlled data. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts via Elementor widget settings that execute when a user accesses the injected page or when an administrator previews the page in Elementor's editor. The vulnerability was partially patched in version 5.1.51.

📍 영향받는 시스템

King Addons for Elementor plugin (WordPress) version 5.1.38 and below

⚔️ 공격 벡터

기여자 이상의 권한을 가진 사용자가 Elementor 위젯 설정에 악성 스크립트를 삽입하여 실행

🛡️ 대응 방법

플러그인을 최신 버전인 5.1.51 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 번호가 5.1.51보다 낮으면 취약한 상태입니다.

Shell / Script
wp plugin list --status=active | grep -i 'king-addons-for-elementor' && wp plugin list --format=json | jq '.[] | select(.name=="king-addons-for-elementor") | .version'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

💻 영향받는 소프트웨어

WordPress