🔍 CVE-2025-24792

4.4
CVSS Score
MEDIUM
2025-01-29
2026-04-15 00:35
✅ 완료

🇰🇷 한글 설명

Snowflake PHP PDO Driver에서 PUT 또는 GET 같은 지원되지 않는 쿼리 실행 시 정수 타입 변환 에러가 발생하여 애플리케이션이 충돌한다. 0.2.0 ~ 3.0.3 버전이 영향을 받으며 3.1.0 버전에서 수정되었다.

💡 쉬운 설명

PHP로 Snowflake 데이터베이스에 연결할 때 특정 명령어를 사용하면 프로그램이 강제 종료될 수 있다. 드라이버를 최신 버전으로 업데이트하면 해결된다.

🇺🇸 원문 (English)

Snowflake PHP PDO Driver is a driver that uses the PHP Data Objects (PDO) extension to connect to the Snowflake database. Snowflake discovered and remediated a vulnerability in the Snowflake PHP PDO Driver where executing unsupported queries like PUT or GET on stages causes a signed-to-unsigned conversion error that crashes the application using the Driver. This vulnerability affects versions 0.2.0 through 3.0.3. Snowflake fixed the issue in version 3.1.0.

📍 영향받는 시스템

Snowflake PHP PDO Driver 버전 0.2.0 ~ 3.0.3

⚔️ 공격 벡터

PUT 또는 GET 쿼리를 unsupported stage operations로 실행하여 애플리케이션 서비스 거부(DoS) 유발

🛡️ 대응 방법

Snowflake PHP PDO Driver를 3.1.0 이상으로 업그레이드

🔧 검증 코드

버전 3.0.3 이하가 출력되면 취약한 상태이며, 3.1.0 이상이거나 '미설치'가 출력되면 안전함

Shell / Script
grep -A 1 'snowflake-pdo' composer.lock 2>/dev/null | grep -oP '"version"\s*:\s*"\K[^"]+' || echo '미설치'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

PHP