🔍 CVE-2025-26760

7.5
CVSS Score
HIGH
2025-02-22
2026-04-29 10:16
✅ 완료

🇰🇷 한글 설명

Wow-Company Calculator Builder 플러그인 1.6.2 이하 버전에서 PHP 파일 포함 함수에 대한 부적절한 입력 검증으로 인해 로컬 파일 포함(LFI) 취약점이 발생합니다. 공격자는 이 취약점을 악용하여 서버의 민감한 파일(설정, 데이터베이스 정보 등)에 접근할 수 있습니다.

💡 쉬운 설명

WordPress의 계산기 빌더 플러그인에서 공격자가 서버의 중요한 파일들을 읽을 수 있는 보안 허점이 있습니다. 플러그인이 사용자의 파일 경로 요청을 제대로 검증하지 않아서 발생하는 문제입니다.

🇺🇸 원문 (English)

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Wow-Company Calculator Builder calculator-builder allows PHP Local File Inclusion.This issue affects Calculator Builder: from n/a through <= 1.6.2.

📍 영향받는 시스템

Wow-Company Calculator Builder plugin <= 1.6.2

⚔️ 공격 벡터

Unauthenticated attacker can include local files via manipulated include/require statement parameters

🛡️ 대응 방법

Update Calculator Builder plugin to version > 1.6.2 or disable the plugin until patch is available

🔧 검증 코드

플러그인 설치 여부와 버전을 확인하여 1.6.2 이하면 업데이트 필요

Shell / Script
grep -r 'calculator-builder' /var/www/html/wp-content/plugins 2>/dev/null | head -1 && find /var/www/html/wp-content/plugins/calculator-builder -name 'calculator-builder.php' -exec grep -h 'Version:' {} \;

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP