🇰🇷 한글 설명
Exim 4.98 미만 버전에서 SQLite 힌트와 ETRN 직렬화가 함께 사용될 때 원격 SQL 인젝션이 발생할 수 있습니다. 특정 비기본 속도 제한 설정이 적용된 경우, 이 문제를 해결하려면 4.99.1 버전으로 업데이트가 필요합니다.
💡 쉬운 설명
메일 서버 소프트웨어인 Exim의 특정 설정에서 해커가 데이터베이스에 몰래 명령어를 주입할 수 있는 취약점입니다. 이를 통해 공격자가 서버의 중요한 정보를 훔치거나 조작할 위험이 있습니다.
🇺🇸 원문 (English)
Exim 4.98 before 4.98.1, when SQLite hints and ETRN serialization are used, allows remote SQL injection. (Resolving SQL injection requires an update to 4.99.1 in certain non-default rate-limit configurations.)
📍 영향받는 시스템
Exim 4.98 미만 버전 (특정 비기본 rate-limit 설정 시 4.99.1 미만 포함)
⚔️ 공격 벡터
원격에서 조작된 SQLite 힌트 및 ETRN 직렬화 데이터를 전송하여 SQL 인젝션 수행
🛡️ 대응 방법
Exim을 최신 버전(최소 4.99.1 이상)으로 업데이트하십시오.
🔧 검증 코드
출력된 버전이 4.98 미만인지 확인하여 취약 여부를 판단합니다.
exim --version 2>/dev/null | grep -oE 'Exim [0-9.]+'