🔍 CVE-2025-30207

7.5
CVSS Score
HIGH
2025-05-13
2026-06-17 09:08
✅ 완료

🇰🇷 한글 설명

Kirby CMS의 PHP 내장 서버를 사용하는 환경에서 경로 탐색(Path Traversal) 취약점이 발견되었습니다. 공격자는 이를 통해 문서 루트 외부의 파일 존재 여부를 확인하여 서버 내 파일 구조를 파악할 수 있습니다. 이 문제는 Kirby 3.9.8.3, 3.10.1.2, 4.7.1 버전에서 패치되었습니다.

💡 쉬운 설명

웹사이트 관리 도구인 Kirby를 개발용 서버로 실행할 때, 공격자가 서버 내부의 다른 파일이 있는지 몰래 훔쳐볼 수 있는 허점이 있습니다. 파일의 내용을 직접 읽지는 못하더라도 어떤 파일이 존재하는지는 알아낼 수 있어 보안에 위협이 됩니다.

🇺🇸 원문 (English)

Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby setups that use PHP's built-in server. Such setups are commonly only used during local development. Sites that use other server software (such as Apache, nginx or Caddy) are not affected. A missing path traversal check allowed attackers to navigate all files on the server that were accessible to the PHP process, including files outside of the Kirby installation. The vulnerable implementation delegated all existing files to PHP, including existing files outside of the document root. This leads to a different response that allows attackers to determine whether the requested file exists. Because Kirby's router only delegates such requests to PHP and does not load or execute them, contents of the files were not exposed as PHP treats requests to files outside of the document root as invalid. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, the maintainers of Kirby have updated the router to check if existing static files are within the document root. Requests to files outside the document root are treated as page requests of the error page and will no longer allow to determine whether the file exists or not.

📍 영향받는 시스템

Kirby versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 (using PHP built-in server)

⚔️ 공격 벡터

PHP 내장 서버를 사용하는 환경에서 경로 탐색(Path Traversal)을 통한 파일 존재 여부 확인

🛡️ 대응 방법

Kirby를 최신 패치 버전(3.9.8.3, 3.10.1.2, 4.7.1 이상)으로 업데이트하거나 Apache, nginx 등 다른 서버 소프트웨어를 사용하십시오.

🔧 검증 코드

현재 설치된 Kirby 버전을 확인하여 패치된 버전(3.9.8.3, 3.10.1.2, 4.7.1 이상)인지 대조합니다.

Shell / Script
php -r 'echo "3.9.8.3
3.10.1.2
4.7.1";' | grep -E '3.9.8.3|3.10.1.2|4.7.1'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

💻 영향받는 소프트웨어

Nginx