🔍 CVE-2025-30845

7.5
CVSS Score
HIGH
2025-03-27
2026-04-23 15:27
✅ 완료

🇰🇷 한글 설명

The Pack Elementor 플러그인의 파일명 처리 미흡으로 인한 PHP 로컬 파일 포함(LFI) 취약점입니다. 공격자가 특정 매개변수를 조작하여 서버의 임의 파일을 읽거나 실행할 수 있습니다. 2.1.1 버전 이하가 영향을 받습니다.

💡 쉬운 설명

The Pack Elementor 플러그인이 사용자 입력을 제대로 검증하지 않아 공격자가 서버 내 파일(/etc/passwd 등)을 읽을 수 있습니다. URL 파라미터 조작만으로 시스템 파일 접근이 가능합니다.

🇺🇸 원문 (English)

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in webangon The Pack Elementor addons the-pack-addon allows PHP Local File Inclusion.This issue affects The Pack Elementor addons: from n/a through <= 2.1.1.

📍 영향받는 시스템

The Pack Elementor addon for WordPress versions <= 2.1.1

⚔️ 공격 벡터

Manipulate file path parameters in plugin requests to exploit include/require statements and read arbitrary local files

🛡️ 대응 방법

Update The Pack Elementor addon to version 2.1.2 or higher immediately

🔧 검증 코드

Extracts plugin version; if result is 2.1.1 or lower (or empty if plugin not found), system is vulnerable

Shell / Script
grep -h 'Version:' /var/www/html/wp-content/plugins/the-pack-addon/the-pack-addon.php 2>/dev/null | grep -oP '\d+\.\d+\.\d+'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP