🔍 CVE-2025-48989

7.5
CVSS Score
HIGH
2025-08-13
2026-06-17 09:30
✅ 완료

🇰🇷 한글 설명

Apache Tomcat의 리소스 해제 취약점으로, HTTP 요청 처리 중 적절히 종료되지 않은 연결이 누적되어 서비스 거부 공격에 노출됩니다. 영향받는 버전은 11.0.0~11.0.9, 10.1.0~10.1.43, 9.0.0~9.0.107이며, 즉시 업그레이드 권고됩니다.

💡 쉬운 설명

Tomcat 웹 서버가 요청 처리 후 연결을 제대로 정리하지 않아, 공격자가 많은 요청을 보내 서버를 다운시킬 수 있습니다. 버전 11.0.10, 10.1.44, 9.0.108 이상으로 업그레이드하면 해결됩니다.

🇺🇸 원문 (English)

Improper Resource Shutdown or Release vulnerability in Apache Tomcat made Tomcat vulnerable to the made you reset attack. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.9, from 10.1.0-M1 through 10.1.43 and from 9.0.0.M1 through 9.0.107. Older, EOL versions may also be affected. Users are recommended to upgrade to one of versions 11.0.10, 10.1.44 or 9.0.108 which fix the issue.

📍 영향받는 시스템

Apache Tomcat 11.0.0-M1~11.0.9, 10.1.0-M1~10.1.43, 9.0.0-M1~9.0.107

⚔️ 공격 벡터

다량의 HTTP 요청을 신속하게 전송하여 서버의 연결 리소스를 고갈시키는 서비스 거부(DoS) 공격

🛡️ 대응 방법

Tomcat을 11.0.10, 10.1.44 또는 9.0.108 이상으로 업그레이드

🔧 검증 코드

명령어 실행 결과로 현재 설치된 Tomcat 버전이 표시되며, 9.0.107 이하, 10.1.43 이하, 11.0.9 이하라면 업그레이드 필요

Shell / Script
dpkg -l tomcat* 2>/dev/null | grep -oP 'tomcat[0-9.]*' | head -1 | xargs -I {} dpkg -l | grep {} | awk '{print $3}'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Apache Tomcat