🔍 CVE-2025-49280

8.1
CVSS Score
HIGH
2025-06-09
2026-04-23 15:31
✅ 완료

🇰🇷 한글 설명

unfoldwp Magty 플러그인에서 PHP include/require 문의 파일명을 부적절하게 제어하여 발생하는 Local File Inclusion(LFI) 취약점. 공격자가 조작된 파일 경로 매개변수를 통해 서버의 임의 파일을 포함시키고 실행할 수 있으며, 시스템 정보 탈취 및 권한 상승으로 이어질 수 있음.

💡 쉬운 설명

Magty 플러그인이 사용자 입력을 제대로 검증하지 않아, 공격자가 서버의 임의 파일을 읽거나 실행할 수 있습니다. 웹사이트의 설정 파일, 데이터베이스 정보 등 민감한 정보가 노출될 위험이 있습니다.

🇺🇸 원문 (English)

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in unfoldwp Magty magty allows PHP Local File Inclusion.This issue affects Magty: from n/a through <= 1.0.6.

📍 영향받는 시스템

unfoldwp Magty plugin version 1.0.6 and earlier on WordPress installations

⚔️ 공격 벡터

Attacker injects malicious file path in URL parameters or POST data targeting include/require functions to read or execute arbitrary server files

🛡️ 대응 방법

Update Magty plugin to version > 1.0.6 immediately, or disable/remove plugin if update unavailable

🔧 검증 코드

플러그인이 설치되어 있으면 경로 또는 플러그인 정보가 표시되며, 존재하면 설치 상태 확인 후 버전 업데이트 필요

Shell / Script
wp plugin list 2>/dev/null | grep -i magty || find /var/www/html/wp-content/plugins -iname '*magty*' 2>/dev/null

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP