🇰🇷 한글 설명
Apache HTTP Server에서 유효 수명이 지난 후 메모리가 늦게 해제되는 취약점이 발견되었습니다. 이 문제는 2.4.17 버전부터 2.4.63 버전까지의 사용자에게 영향을 미칩니다.
💡 쉬운 설명
프로그램이 사용이 끝난 메모리를 즉시 비우지 않고 남겨두어 발생하는 문제입니다. 이로 인해 시스템의 메모리가 낭비되거나 보안상 문제가 생길 수 있습니다.
🇺🇸 원문 (English)
Late Release of Memory after Effective Lifetime vulnerability in Apache HTTP Server.
This issue affects Apache HTTP Server: from 2.4.17 up to 2.4.63.
Users are recommended to upgrade to version 2.4.64, which fixes the issue.
📍 영향받는 시스템
Apache HTTP Server 2.4.17 ~ 2.4.63
⚔️ 공격 벡터
메모리 관리 오류를 악용하여 시스템 자원을 고갈시키거나 예기치 않은 동작을 유도할 수 있습니다.
🛡️ 대응 방법
Apache HTTP Server를 취약점이 해결된 2.4.64 버전 이상으로 업그레이드하십시오.
🔧 검증 코드
명령어 결과에 취약한 버전 범위(2.4.17~2.4.63)가 출력되면 업데이트가 필요합니다.
httpd -v 2>/dev/null || apache2 -v 2>/dev/null | grep -E 'Apache/2\.(4\.(1[7-9]|[2-5][0-9]|6[0-3]))'