🔍 CVE-2025-53107

7.5
CVSS Score
HIGH
2025-07-01
2026-04-15 00:35
✅ 완료

🇰🇷 한글 설명

@cyanheads/git-mcp-server 2.1.5 미만 버전에서 child_process.exec()에 전달하는 입력값을 검증하지 않아 명령 인젝션 취약점이 발생합니다. 공격자는 shell 메타문자를 포함한 악의적인 입력을 통해 서버 권한으로 임의의 시스템 명령을 실행할 수 있습니다. MCP 클라이언트의 git 명령 처리 중 간접 프롬프트 인젝션으로도 악용 가능합니다.

💡 쉬운 설명

@cyanheads/git-mcp-server의 구형 버전이 사용자 입력을 안전하게 확인하지 않아, 해커가 숨겨진 명령을 통해 서버를 제어할 수 있습니다. 이는 원격 코드 실행으로 이어져 서버의 모든 권한을 장악당할 위험이 있습니다.

🇺🇸 원문 (English)

@cyanheads/git-mcp-server is an MCP server designed to interact with Git repositories. Prior to version 2.1.5, there is a command injection vulnerability caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, >, &&, etc.). An MCP Client can be instructed to execute additional actions for example via indirect prompt injection when asked to read git logs. This issue has been patched in version 2.1.5.

📍 영향받는 시스템

@cyanheads/git-mcp-server 버전 2.1.4 이하

⚔️ 공격 벡터

MCP 클라이언트의 git 로그/명령 입력에 shell 메타문자(|, >, &&, ;, `)를 삽입하여 임의 시스템 명령 실행

🛡️ 대응 방법

@cyanheads/git-mcp-server를 2.1.5 이상으로 즉시 업그레이드

🔧 검증 코드

버전 번호가 2.1.5 이상이면 패치됨, 2.1.4 이하면 취약

Shell / Script
npm list @cyanheads/git-mcp-server 2>/dev/null | grep -oP '@cyanheads/git-mcp-server@\K[0-9.]+'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Git