🔍 CVE-2025-54571

6.1
CVSS Score
MEDIUM
2025-08-06
2026-06-17 09:40
✅ 완료

🇰🇷 한글 설명

ModSecurity 2.9.11 이하 버전에서 공격자가 HTTP 응답의 Content-Type을 변조할 수 있는 취약점이 발견되었습니다. 이로 인해 XSS(교차 사이트 스크립팅) 공격이나 임의의 스크립트 소스 코드 노출이 발생할 수 있습니다.

💡 쉬운 설명

웹 방화벽이 웹사이트의 응답 형식을 제대로 통제하지 못해 발생하는 문제입니다. 해커가 가짜 정보를 진짜 데이터처럼 속여 사용자 브라우저에서 악성 코드를 실행하게 만들 수 있습니다.

🇺🇸 원문 (English)

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. In versions 2.9.11 and below, an attacker can override the HTTP response’s Content-Type, which could lead to several issues depending on the HTTP scenario. For example, we have demonstrated the potential for XSS and arbitrary script source code disclosure in the latest version of mod_security2. This issue is fixed in version 2.9.12.

📍 영향받는 시스템

ModSecurity 2.9.11 및 그 이하 모든 버전

⚔️ 공격 벡터

조작된 HTTP 요청을 통해 서버의 응답 헤더인 Content-Type을 덮어쓰는 방식

🛡️ 대응 방법

ModSecurity를 최신 버전인 2.9.12 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 정보가 2.9.12 미만인지 확인하여 취약 여부를 판단합니다.

Shell / Script
modsecurity -v 2>/dev/null || apache2ctl -M | grep mod_security 2>/dev/null

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

💻 영향받는 소프트웨어

Nginx