🔍 CVE-2025-58098

8.3
CVSS Score
HIGH
2025-12-05
2026-09-25 23:10
✅ 완료

🇰🇷 한글 설명

Apache HTTP Server 2.4.65 및 이전 버전에서 Server Side Includes(SSI)가 활성화되고 mod_cgid가 사용될 경우, 셸 이스케이프 처리가 된 쿼리 문자열이 #exec cmd="..." 지시문에 전달되는 취약점이 있습니다. 이로 인해 공격자가 원격에서 명령을 실행할 수 있는 위험이 존재합니다.

💡 쉬운 설명

웹 서버의 특정 설정이 켜져 있을 때, 공격자가 입력한 특수 문자가 제대로 걸러지지 않아 서버에 몰래 명령을 내릴 수 있는 문제입니다. 이를 통해 해커가 서버의 제어권을 탈취할 수 있습니다.

🇺🇸 원문 (English)

Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.

📍 영향받는 시스템

Apache HTTP Server 2.4.66 미만 버전 (mod_cgid 및 SSI 활성화 시)

⚔️ 공격 벡터

SSI가 활성화된 상태에서 조작된 쿼리 문자열을 통해 #exec 지시문에 명령어를 주입하는 방식

🛡️ 대응 방법

Apache HTTP Server를 취약점이 해결된 2.4.66 버전 이상으로 업그레이드하십시오.

🔧 검증 코드

출력된 버전이 Apache/2.4.65 이하(예: 2.4.62, 2.4.65 등)라면 취약한 상태입니다.

Shell / Script
httpd -v 2>/dev/null || apache2 -v 2>/dev/null | grep -E 'Apache/2\.(4\.[0-5][0-9])'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L

💻 영향받는 소프트웨어

Apache HTTP Server