🔍 CVE-2025-58948

8.1
CVSS Score
HIGH
2025-12-18
2026-04-27 20:16
✅ 완료

🇰🇷 한글 설명

axiomthemes Aromatica 플러그인 버전 1.8 이하에서 PHP include/require 문의 파일명 제어가 부적절하여 로컬 파일 포함(LFI) 취약점이 발생합니다. 공격자가 조작된 파일 경로를 입력하여 서버의 민감한 파일(설정 파일, 시스템 파일 등)을 읽을 수 있습니다.

💡 쉬운 설명

WordPress 테마/플러그인에서 사용자 입력을 충분히 검증하지 않아 서버의 파일들에 접근할 수 있는 문제입니다. 공격자가 URL에 특정 경로를 입력하면 데이터베이스 설정, 사용자 정보 등 민감한 파일을 볼 수 있습니다.

🇺🇸 원문 (English)

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in axiomthemes Aromatica aromatica allows PHP Local File Inclusion.This issue affects Aromatica: from n/a through <= 1.8.

📍 영향받는 시스템

axiomthemes Aromatica WordPress theme/plugin version 1.8 and below

⚔️ 공격 벡터

Unauthenticated attacker can manipulate file inclusion parameters (e.g., URL parameters, POST data) to read arbitrary files via directory traversal sequences like ../../etc/passwd

🛡️ 대응 방법

Update Aromatica to version 1.9 or later; implement input validation and sanitization for all file path parameters; use whitelist-based file inclusion

🔧 검증 코드

WordPress가 설치된 경우 Aromatica 플러그인/테마의 버전을 확인합니다. 1.8 이하이면 취약하므로 즉시 업데이트 필요. 아무 결과도 없으면 플러그인이 설치되지 않은 상태

Shell / Script
grep -r 'Aromatica' /var/www/html/wp-content/themes/ /var/www/html/wp-content/plugins/ 2>/dev/null | grep -i 'version\|Version' | head -1

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP