🔍 CVE-2025-62525

7.9
CVSS Score
HIGH
2025-10-22
2026-10-19 16:10
✅ 완료

🇰🇷 한글 설명

OpenWrt 24.10.4 미만 버전에서 ltq-ptm 드라이버의 ioctl 취약점으로 인해 로컬 사용자가 임의의 커널 메모리를 읽고 쓸 수 있습니다. 이 취약점은 Lantiq/Intel/MaxLinear SoC를 사용하는 특정 PTM 모드 DSL 환경에서 발생하며, 샌드박스 탈출 공격에 악용될 수 있습니다.

💡 쉬운 설명

기기 내부의 제한된 권한을 가진 사용자가 시스템의 가장 핵심적인 영역인 커널 메모리에 접근하여 내용을 바꾸거나 훔쳐볼 수 있는 보안 결함입니다. 이를 통해 격리된 환경을 뚫고 시스템 전체를 장악할 위험이 있습니다.

🇺🇸 원문 (English)

OpenWrt Project is a Linux operating system targeting embedded devices. Prior to version 24.10.4, local users could read and write arbitrary kernel memory using the ioctls of the ltq-ptm driver which is used to drive the datapath of the DSL line. This only effects the lantiq target supporting xrx200, danube and amazon SoCs from Lantiq/Intel/MaxLinear with the DSL in PTM mode. The DSL driver for the VRX518 is not affected. ATM mode is also not affected. Most VDSL lines use PTM mode and most ADSL lines use ATM mode. OpenWrt is normally running as a single user system, but some services are sandboxed. This vulnerability could allow attackers to escape a ujail sandbox or other contains. This is fixed in OpenWrt 24.10.4. There are no workarounds.

📍 영향받는 시스템

OpenWrt 24.10.4 미만 버전 중 Lantiq/Intel/MaxLinear SoC(xrx200, danube, amazon)를 사용하는 PTM 모드 DSL 환경

⚔️ 공격 벡터

로컬 사용자가 ltq-ptm 드라이버의 ioctl 인터페이스를 호출하여 커널 메모리에 접근

🛡️ 대응 방법

OpenWrt 버전을 24.10.4 이상으로 업데이트

🔧 검증 코드

출력된 OpenWrt 버전이 24.10.4 미만인지 확인하여 취약 여부를 판단합니다.

Shell / Script
opkg list-installed | grep -E 'openwrt'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:H

💻 영향받는 소프트웨어

Linux Kernel