🔍 CVE-2025-62801

7.8
CVSS Score
HIGH
2025-10-28
2026-10-08 11:10
✅ 완료

🇰🇷 한글 설명

FastMCP 2.13.0 미만 버전에서 발생하는 커맨드 인젝션 취약점입니다. 공격자가 server_name 필드를 조작할 수 있다면, fastmcp install cursor를 실행하는 Windows 호스트에서 임의의 OS 명령어를 실행할 수 있습니다.

💡 쉬운 설명

FastMCP 프로그램의 특정 설정값을 조작하여 컴퓨터에 몰래 명령을 내릴 수 있는 보안 약점입니다. 이로 인해 공격자가 윈도우 컴퓨터를 마음대로 조종할 위험이 있습니다.

🇺🇸 원문 (English)

FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0, a command-injection vulnerability lets any attacker who can influence the server_name field of an MCP execute arbitrary OS commands on Windows hosts that run fastmcp install cursor. This vulnerability is fixed in 2.13.0.

📍 영향받는 시스템

FastMCP 2.13.0 미만 버전 (Windows 환경)

⚔️ 공격 벡터

MCP의 server_name 필드에 악성 명령어를 삽입하여 실행

🛡️ 대응 방법

FastMCP를 2.13.0 이상 버전으로 업데이트

🔧 검증 코드

출력된 버전 번호가 2.13.0보다 낮은지 확인합니다.

Shell / Script
pip show fastmcp | grep Version

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H