🔍 CVE-2025-64111

0.0
CVSS Score
UNKNOWN
2026-02-06
2026-02-06 21:57
✅ 완료

🇰🇷 한글 설명

Gogs는 오픈 소스 자체 호스팅 Git 서비스입니다. 버전 0.13.3 및 이전 버전에서는 CVE-2024-56731의 불充分한 패치로 인해 여전히 .git 디렉토리의 파일을 업데이트하고 원격 명령어 실행을 달성할 수 있습니다. 이 문제는 버전 0.13.4 및 0.14.0+dev에서 패치되었습니다.

💡 쉬운 설명

Gogs의 이전 버전에서 원격 명령어 실행이 가능합니다. 버전 0.13.3 및 이전 버전에서 CVE-2024-56731의 패치가 불충분하여 여전히 취약점이 존재합니다. 버전 0.13.4 또는 0.14.0+dev로 업데이트하여 취약점을 해결할 수 있습니다.

🇺🇸 원문 (English)

Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, due to the insufficient patch for CVE-2024-56731, it's still possible to update files in the .git directory and achieve remote command execution. This issue has been patched in versions 0.13.4 and 0.14.0+dev.

📍 영향받는 시스템

Gogs 버전 0.13.3 및 이전 버전

⚔️ 공격 벡터

원격 명령어 실행

🛡️ 대응 방법

Gogs를 버전 0.13.4 또는 0.14.0+dev로 업데이트하세요.

🔧 검증 코드

로컬 시스템에서 Python을 실행하여 Gogs 서버의 취약점을 확인하세요. 'your-gogs-server.com'을 실제 Gogs 서버 주소로 바꾸세요. Python requests 라이브러리가 설치되어 있어야 합니다.

Shell / Script
import requests
response = requests.get('https://your-gogs-server.com/.git/HEAD')
if response.status_code == 200:
    print({"result": "취약", "reason": "원격에서 .git 디렉토리에 접근할 수 있습니다."})
else:
    print({"result": "양호", "reason": "원격에서 .git 디렉토리에 접근할 수 없습니다."})

💻 영향받는 소프트웨어

Git