🔍 CVE-2025-64751

8.8
CVSS Score
HIGH
2025-11-21
2026-10-19 13:10
✅ 완료

🇰🇷 한글 설명

OpenFGA v1.4.0에서 v1.11.0 버전 사이에서 특정 Check 및 ListObject 호출 시 부적절한 정책 집행이 발생하는 취약점이 발견되었습니다. 이로 인해 권한이 없는 사용자가 허용되지 않은 데이터에 접근할 수 있는 위험이 있습니다. 해당 문제는 v1.11.1 버전에서 패치되었습니다.

💡 쉬운 설명

권한을 확인하는 시스템이 규칙을 제대로 지키지 않아, 허락되지 않은 사람이 정보를 볼 수 있는 보안 구멍이 생겼습니다. 마치 출입증이 없는 사람이 문을 열고 들어올 수 있는 것과 같습니다.

🇺🇸 원문 (English)

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.

📍 영향받는 시스템

OpenFGA v1.4.0 ~ v1.11.0 (Helm chart 0.1.34 ~ 0.2.48, Docker 1.4.0 ~ 1.11.0)

⚔️ 공격 벡터

특정 Check 또는 ListObject API 호출을 통한 권한 우회 공격

🛡️ 대응 방법

OpenFGA를 최신 패치 버전인 v1.11.1 이상으로 업데이트하십시오.

🔧 검증 코드

출력 결과에 취약한 버전 범위가 나타나면 업데이트가 필요한 상태입니다.

Shell / Script
docker inspect openfga --format '{{.Config.Image}}' | grep -E 'openfga:(1\[.4-1\.11\]|0\.1\.3[4-9]|0\.2\.4[0-8])'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Docker