🔍 CVE-2025-65082

6.5
CVSS Score
MEDIUM
2025-12-05
2026-09-25 23:10
✅ 완료

🇰🇷 한글 설명

Apache HTTP Server에서 환경 변수 설정 시 발생하는 부적절한 중화 취약점입니다. Apache 설정으로 설정된 환경 변수가 CGI 프로그램용으로 계산된 변수를 예기치 않게 덮어쓸 수 있습니다.

💡 쉬운 설명

서버 설정값이 원래 있어야 할 중요한 정보를 가로채거나 바꿀 수 있는 문제입니다. 이로 인해 웹 서버에서 실행되는 프로그램이 잘못된 정보를 읽게 될 위험이 있습니다.

🇺🇸 원문 (English)

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs. This issue affects Apache HTTP Server from 2.4.0 through 2.4.65. Users are recommended to upgrade to version 2.4.66 which fixes the issue.

📍 영향받는 시스템

Apache HTTP Server 2.4.0 ~ 2.4.65

⚔️ 공격 벡터

Apache 설정 파일에 정의된 환경 변수를 통해 CGI 프로그램의 실행 환경을 조작

🛡️ 대응 방법

Apache HTTP Server를 취약점이 해결된 2.4.66 버전 이상으로 업그레이드

🔧 검증 코드

출력된 버전이 Apache/2.4.0에서 2.4.65 사이라면 해당 취약점에 노출된 상태입니다.

Shell / Script
httpd -v 2>/dev/null || apache2 -v 2>/dev/null | grep -E 'Apache/2.4.[0-6][0-5]'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

💻 영향받는 소프트웨어

Apache HTTP Server