🇰🇷 한글 설명
WBCE CMS 1.6.4 미만 버전에서 발생하는 권한 상승 취약점입니다. 저권한 사용자가 /admin/users/save.php 요청 시 groups[] 파라미터를 조작하여 관리자 그룹으로 권한을 상승시킬 수 있습니다. 서버 측 검증 부재로 인해 공격자는 관리자 권한을 획득하여 시스템 전체를 장악할 수 있습니다.
💡 쉬운 설명
일반 사용자 계정이 시스템 설정을 몰래 조작하여 관리자 권한을 뺏어올 수 있는 보안 구멍입니다. 이 권한을 얻게 되면 웹사이트의 모든 내용을 마음대로 바꾸거나 삭제할 수 있습니다.
🇺🇸 원문 (English)
WBCE CMS is a content management system. Prior to version 1.6.4, a low-privileged user in WBCE CMS can escalate their privileges to the Administrators group by manipulating the groups[] parameter in the /admin/users/save.php request. The UI restricts users to assigning only their existing group, but server-side validation is missing, allowing attackers to overwrite their group membership and obtain full administrative access. This results in a complete compromise of the CMS. This issue has been patched in version 1.6.4.
📍 영향받는 시스템
WBCE CMS 1.6.4 미만 모든 버전
⚔️ 공격 벡터
/admin/users/save.php 요청 시 groups[] 파라미터 조작을 통한 서버 측 검증 우회
🛡️ 대응 방법
WBCE CMS를 최신 보안 패치가 적용된 버전 1.6.4 이상으로 업데이트하십시오.
🔧 검증 코드
명령어 실행 결과로 1.6.0부터 1.6.3 사이의 버전이 출력되면 취약한 상태입니다.
curl -s http://<target_ip>/version.php | grep -E '1.6\[0-3\]'
📊 CVSS Vector String
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
💻 영향받는 소프트웨어
Multi-Domain Security Management Server