🔍 CVE-2025-65105

4.5
CVSS Score
MEDIUM
2025-12-02
2026-10-18 18:10
✅ 완료

🇰🇷 한글 설명

Apptainer 1.4.5 미만 버전에서 컨테이너가 AppArmor 또는 SELinux 보안 프로필 설정을 비활성화할 수 있는 취약점이 존재합니다. 이로 인해 컨테이너 내 작업에 대한 보안 제한이 무력화될 수 있습니다.

💡 쉬운 설명

컨테이너를 실행할 때 적용되어야 하는 보안 방어막(AppArmor, SELinux)을 컨테이너 스스로가 꺼버릴 수 있는 문제입니다. 이로 인해 컨테이너가 시스템에 더 많은 권한을 행사할 위험이 있습니다.

🇺🇸 원문 (English)

Apptainer is an open source container platform. In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor:<profile> and --security=selinux:<label> which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. This vulnerability is fixed in 1.4.5.

📍 영향받는 시스템

Apptainer versions < 1.4.5

⚔️ 공격 벡터

취약한 버전의 Apptainer를 사용하여 보안 옵션이 비활성화된 컨테이너를 실행

🛡️ 대응 방법

Apptainer를 1.4.5 버전 이상으로 업데이트

🔧 검증 코드

출력된 버전이 1.4.5 미만(예: 1.4.4 이하)이면 취약한 상태입니다.

Shell / Script
apptainer --version | grep -E '1\.[0-4]\.[0-4]'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L

💻 영향받는 소프트웨어

Magento Open Source