🇰🇷 한글 설명
Apache HTTP Server의 AllowOverride FileInfo 취약점으로 인해 mod_userdir 및 suexec 우회가 가능합니다. .htaccess 파일에서 RequestHeader 지시어를 사용할 수 있는 사용자는 일부 CGI 스크립트를 의도하지 않은 사용자 ID로 실행할 수 있습니다.
💡 쉬운 설명
웹 서버 설정 오류를 이용해 권한이 없는 사용자가 다른 사용자의 권한으로 프로그램을 실행할 수 있는 보안 약점입니다. 이를 통해 서버 내의 보안 경계가 무너질 위험이 있습니다.
🇺🇸 원문 (English)
mod_userdir+suexec bypass via AllowOverride FileInfo vulnerability in Apache HTTP Server. Users with access to use the RequestHeader directive in htaccess can cause some CGI scripts to run under an unexpected userid.
This issue affects Apache HTTP Server: from 2.4.7 through 2.4.65.
Users are recommended to upgrade to version 2.4.66, which fixes the issue.
📍 영향받는 시스템
Apache HTTP Server 2.4.7 ~ 2.4.65
⚔️ 공격 벡터
.htaccess 파일 내 RequestHeader 지시어를 조작하여 CGI 스크립트의 실행 권한을 탈취
🛡️ 대응 방법
Apache HTTP Server를 취약점이 해결된 버전인 2.4.66 이상으로 업그레이드
🔧 검증 코드
출력된 버전이 2.4.7에서 2.4.65 사이라면 해당 취약점에 노출된 상태입니다.
httpd -v 2>/dev/null || apache2 -v 2>/dev/null | grep -E 'Apache/2\.(4\.(7|[8-9]|[1-5][0-9]|6[0-5]))'