🔍 CVE-2025-66236

7.5
CVSS Score
HIGH
2026-04-13
2026-11-03 07:17
✅ 완료

🇰🇷 한글 설명

Airflow 3.2.0 이전 버전에서는 배포 관리자가 Airflow의 보안 모델과 워크로드 격리 방식을 명확히 인지하지 못할 경우 보안 취약점이 발생할 수 있습니다. 이로 인해 역할 격리 및 보안 설정이 의도와 다르게 구성될 위험이 있습니다. 따라서 보안 모델을 준수하는 안전한 배포를 위해 Airflow 3.2.0 이상으로 업그레이드가 권장됩니다.

💡 쉬운 설명

Airflow를 설치하고 설정할 때 보안 규칙을 제대로 지키지 않으면 해킹 위험이 생길 수 있는 문제입니다. 안전하게 사용하려면 최신 버전인 3.2.0으로 업데이트하고 보안 가이드를 따라야 합니다.

🇺🇸 원문 (English)

Before Airflow 3.2.0, it was unclear that secure Airflow deployments require the Deployment Manager to take appropriate actions and pay attention to security details and security model of Airflow. Some assumptions the Deployment Manager could make were not clear or explicit enough, even though Airflow's intentions and security model of Airflow did not suggest different assumptions. The overall security model [1], workload isolation [2], and JWT authentication details [3] are now described in more detail. Users concerned with role isolation and following the Airflow security model of Airflow are advised to upgrade to Airflow 3.2, where several security improvements have been implemented. They should also read and follow the relevant documents to make sure that their deployment is secure enough. It also clarifies that the Deployment Manager is ultimately responsible for securing your Airflow deployment. This had also been communicated via Airflow 3.2.0 Blog announcement [4]. [1] Security Model: https://airflow.apache.org/docs/apache-airflow/stable/security/jwt_token_authentication.html [2] Workload isolation: https://airflow.apache.org/docs/apache-airflow/stable/security/workload.html [3] JWT Token authentication: https://airflow.apache.org/docs/apache-airflow/stable/security/jwt_token_authentication.html [4] Airflow 3.2.0 Blog announcement: https://airflow.apache.org/blog/airflow-3.2.0/ Users are recommended to upgrade to version 3.2.0, which fixes this issue.

📍 영향받는 시스템

Apache Airflow 3.2.0 미만 모든 버전

⚔️ 공격 벡터

부적절한 배포 설정 및 보안 모델 미준수를 통한 권한 상승 또는 격리 우회

🛡️ 대응 방법

Apache Airflow를 3.2.0 버전 이상으로 업그레이드하고 공식 보안 가이드를 준수하여 재배포

🔧 검증 코드

출력된 버전이 3.2.0보다 낮으면 취약한 상태이며, 3.2.0 이상이면 안전합니다.

Shell / Script
airflow version | grep -E 'Apache Airflow [0-9]+\.[0-9]+.[0-9]+'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N