🔍 CVE-2025-66457

8.8
CVSS Score
HIGH
2025-12-09
2026-10-14 21:10
✅ 완료

🇰🇷 한글 설명

Elysia 프레임워크 1.4.17 이하 버전에서 쿠키 설정이 적절한 검증 없이 컴파일된 라우트에 주입되어 임의 코드가 실행될 수 있는 취약점이 발견되었습니다. 이 취약점은 다른 취약점(GHSA-hxj9-33pp-j2cc)과 결합될 경우 완전한 원격 코드 실행(RCE)으로 이어질 수 있습니다. 공격을 위해서는 쿠키 설정에 대한 쓰기 권한이 필요합니다.

💡 쉬운 설명

웹사이트의 쿠키 설정 값을 조작하여 해커가 서버에서 마음대로 명령어를 실행할 수 있는 보안 약점입니다. 쿠키 설정 파일에 접근할 수 있는 권한이 있다면 시스템 전체가 위험해질 수 있습니다.

🇺🇸 원문 (English)

Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Versions 1.4.17 and below are subject to arbitrary code execution from cookie config. When dynamic cookies are enabled (e.g. there an existing cookie schema), the cookie config is injected into the compiled route without first being sanitised. Availability of this exploit is generally low, but when combined with GHSA-hxj9-33pp-j2cc, it allows for a full RCE chain. An attack requires write access to either the Elysia app's source code (in which case the vulnerability is meaningless) or write access to the cookie config (perhaps where it is assumed to be provisioned by the environment). This issue is fixed in version 1.4.18.

📍 영향받는 시스템

Elysia Framework 1.4.17 및 그 이하 모든 버전

⚔️ 공격 벡터

쿠키 설정(cookie config)에 악성 코드를 주입하여 컴파일된 라우트를 통해 실행

🛡️ 대응 방법

Elysia 프레임워크를 최신 버전인 1.4.18 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 번호가 1.4.18 미만(예: 1.4.17)인지 확인하십시오.

Shell / Script
npm list elysia | grep elysia

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Magento Open Source