🔍 CVE-2025-69406

8.1
CVSS Score
HIGH
2026-02-20
2026-04-15 00:35
✅ 완료

🇰🇷 한글 설명

ThemeREX FreightCo 플러그인에서 PHP include/require 문에 대한 부적절한 입력값 검증으로 인해 발생하는 로컬 파일 포함(LFI) 취약점입니다. 공격자는 악의적인 파일 경로를 주입하여 서버의 임의 파일을 실행할 수 있으며, 버전 1.1.7 이하에서 발생합니다.

💡 쉬운 설명

FreightCo 플러그인이 외부에서 들어오는 파일 경로를 제대로 검사하지 않아서, 해커가 서버의 다른 파일을 실행시킬 수 있는 결함입니다. 이를 통해 웹사이트의 데이터를 빼내거나 전체 시스템을 장악당할 수 있습니다.

🇺🇸 원문 (English)

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in ThemeREX FreightCo freightco allows PHP Local File Inclusion.This issue affects FreightCo: from n/a through <= 1.1.7.

📍 영향받는 시스템

ThemeREX FreightCo WordPress plugin version <= 1.1.7

⚔️ 공격 벡터

Attacker injects arbitrary file paths into vulnerable include/require parameters to execute local or remote files with server privileges

🛡️ 대응 방법

Update FreightCo plugin to version 1.1.8 or later; disable plugin immediately if update unavailable

🔧 검증 코드

버전이 1.1.7 이하이면 취약함; 1.1.8 이상이면 안전함; 출력이 없으면 플러그인이 설치되지 않았음

Shell / Script
cat /var/www/html/wp-content/plugins/freightco/readme.txt 2>/dev/null | grep -oP 'Stable tag:\s*\K[0-9.]+' || echo 'Plugin not found'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP