🔍 CVE-2026-100720

8.7
CVSS Score
HIGH
2026-09-26
2026-09-26 23:16
✅ 완료

🇰🇷 한글 설명

Froxlor 2.0.0부터 2.3.10 버전에서 저장형 XSS 취약점이 발견되었습니다. 고객이 SSL 인증서를 업로드할 때 발행자 조직(issuer['O']) 필드에 악성 스크립트를 삽입하면, 관리자가 인증서 목록을 확인할 때 해당 스크립트가 실행되어 관리자 권한 탈취 및 서버 루트 권한 실행으로 이어질 수 있습니다.

💡 쉬운 설명

사용자가 인증서 정보에 몰래 악성 코드를 숨겨 놓으면, 관리자가 이를 확인하는 순간 관리자의 계정이 해킹될 수 있는 문제입니다. 해커가 관리자 권한을 얻으면 서버 전체를 마음대로 조종할 수도 있어 매우 위험합니다.

🇺🇸 원문 (English)

Froxlor 2.0.0 through 2.3.10 is vulnerable to stored cross-site scripting. When a customer (the lowest-privileged authenticated role) uploads an SSL certificate for one of their own domains, the Certificates API add()/update() methods parse it with openssl_x509_parse() and store the issuer organization (issuer['O']) value verbatim without sanitization. Froxlor's table-listing renderer then emits scalar cells through Twig's `raw` filter, disabling HTML auto-escaping, so when an administrator or reseller opens Domains > SSL certificates the attacker-supplied issuer value executes as script in the privileged user's session. This crosses a privilege boundary from customer to admin and can result in full administrator account takeover; because a Froxlor admin controls webserver, DNS, and PHP configuration applied by a cron job running as root, the issue can be further escalated to command execution as root on the managed server. The issue is fixed in Froxlor 2.3.12.

📍 영향받는 시스템

Froxlor 2.0.0 ~ 2.3.10

⚔️ 공격 벡터

악성 스크립트가 포함된 SSL 인증서를 업로드하여 관리자의 세션에서 코드를 실행시키는 저장형 XSS

🛡️ 대응 방법

Froxlor를 최신 보안 패치가 적용된 버전인 2.3.12 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 결과에서 Froxlor의 버전을 확인하여 2.3.12 미만인지 확인하십시오.

Shell / Script
php -r 'echo "Froxlor Version Check";' && grep -r "Froxlor" /var/www/html/ 2>/dev/null | grep -E 'version' || echo 'Version info not found'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

💻 영향받는 소프트웨어

OpenSSL