🔍 CVE-2026-10148

6.4
CVSS Score
MEDIUM
2026-09-12
2026-09-14 20:16
✅ 완료

🇰🇷 한글 설명

WordPress의 Booking for Appointments and Events Calendar 플러그인 2.4.9 이하 버전에서 저장형 XSS 취약점이 발견되었습니다. Elementor 위젯의 'load_manually' 매개변수에 대한 입력값 검증 및 출력 이스케이프 처리가 미흡하여 발생합니다. 이를 통해 기여자(Contributor) 이상의 권한을 가진 인증된 공격자가 악성 스크립트를 삽입할 수 있습니다.

💡 쉬운 설명

웹사이트 관리 권한이 있는 사용자가 페이지에 몰래 악성 코드를 심을 수 있는 보안 약점입니다. 이 코드가 실행되면 해당 페이지를 방문하는 다른 사용자들의 정보가 탈취될 위험이 있습니다.

🇺🇸 원문 (English)

The Booking for Appointments and Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple Elementor widgets in versions up to and including 2.4.9. This is due to insufficient input sanitization and output escaping on the 'load_manually' parameter in the render() methods of classes. This makes it possible for authenticated attackers, with Contributor-level access and above who can use Elementor, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.4.8.

📍 영향받는 시스템

WordPress Booking for Appointments and Events Calendar plugin (버전 2.4.9 이하)

⚔️ 공격 벡터

Elementor 위젯의 'load_manually' 매개변수에 악성 스크립트를 삽입하여 페이지에 저장

🛡️ 대응 방법

플러그인을 최신 버전으로 업데이트하여 보안 패치를 적용하십시오.

🔧 검증 코드

명령어 결과에 해당 플러그인이 표시되면 설치된 것이며, 설치된 버전이 2.4.9 이하인지 확인해야 합니다.

Shell / Script
wp plugin list --status=active | grep -E 'booking-for-appointments-and-events-calendar'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

💻 영향받는 소프트웨어

WordPress