🔍 CVE-2026-103413

8.8
CVSS Score
HIGH
2026-10-09
2026-10-15 19:17
✅ 완료

🇰🇷 한글 설명

Apache Camel Karavan에서 발생하는 입력값 검증 미흡 취약점으로, 배포 시 kubernetes.yaml 파일의 리소스 종류를 제한하지 않고 보안에 민감한 옵션을 필터링하지 않습니다. 이로 인해 인증된 사용자가 서비스 계정 권한 내에서 호스트 네트워크나 특권 컨테이너와 같은 임의의 쿠버네티스 리소스를 생성할 수 있습니다.

💡 쉬운 설명

프로그램이 사용자가 올린 설정 파일을 검사하지 않고 그대로 실행하여 발생하는 문제입니다. 공격자가 이를 이용해 시스템의 핵심 권한을 탈취하거나 서버 전체를 제어할 수 있는 위험한 설정을 강제로 적용할 수 있습니다.

🇺🇸 원문 (English)

Improper input validation vulnerability in Apache Camel Karavan. When a deployment was started, Karavan unmarshalled a project's `kubernetes.yaml` and applied every resource it contained to the cluster without restricting the resource kinds, without rejecting security-sensitive pod options, and without pinning the target namespace. An authenticated user of any role could therefore have Karavan apply arbitrary Kubernetes resources within the reach of its service account, including pods requesting hostNetwork, hostPID, hostIPC, hostPath volumes, host ports, privileged containers, privilege escalation or added capabilities. This issue affects Apache Camel Karavan: from 4.0.0 before 4.22.1. Users are recommended to upgrade to version 4.22.1, which fixes the issue.

📍 영향받는 시스템

Apache Camel Karavan 4.0.0 미만 4.22.1 이전 버전

⚔️ 공격 벡터

인증된 사용자가 악의적인 설정이 포함된 kubernetes.yaml 파일을 업로드하여 배포를 시작함

🛡️ 대응 방법

Apache Camel Karavan을 4.22.1 버전 이상으로 업그레이드하십시오.

🔧 검증 코드

명령어 실행 결과로 4.22.1 이상의 버전 번호가 출력되면 취약점이 해결된 상태입니다.

Shell / Script
curl -s http://<karavan-endpoint>/version | grep -E '4\\.22\.1'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Kubernetes