🔍 CVE-2026-104893

5.4
CVSS Score
MEDIUM
2026-10-05
2026-10-06 18:16
✅ 완료

🇰🇷 한글 설명

오픈소스 프로젝트 관리 도구인 Plane의 1.4.0 미만 버전에서 발생하는 취약점입니다. 인증된 사용자가 API 토큰의 rate_limit 필드를 서버 측 검증 없이 임의로 수정할 수 있어, API 속도 제한을 우회하고 대량의 자동화된 요청을 통해 리소스를 고갈시킬 수 있습니다.

💡 쉬운 설명

로그인한 사용자가 시스템의 사용량 제한 설정을 마음대로 높일 수 있는 보안 허점입니다. 이를 통해 공격자는 제한 없이 많은 요청을 보내 서버를 느리게 만들거나 마비시킬 수 있습니다.

🇺🇸 원문 (English)

Plane is an open-source project management tool. Prior to 1.4.0, GET /api/users/api-tokens/ allows an authenticated user to retrieve API-token records, while PATCH /api/users/api-tokens/{token_id}/ allows the user to modify the token's allowed_rate_limit field without server-side validation or a maximum value. A user can raise the limit arbitrarily and bypass intended API rate-limiting controls, enabling high-volume automated requests, backend resource abuse, and possible resource exhaustion. This issue is fixed in 1.4.0.

📍 영향받는 시스템

Plane (version < 1.4.0)

⚔️ 공격 벡터

인증된 사용자가 PATCH /api/users/api-tokens/{token_id}/ API를 호출하여 allowed_rate_limit 값을 임의로 수정

🛡️ 대응 방법

Plane 버전을 1.4.0 이상으로 업데이트

🔧 검증 코드

출력된 버전 정보가 1.4.0 미만인 경우 해당 취약점에 노출된 상태입니다.

Shell / Script
curl -s http://<target-ip>/api/version | grep -E '"version": "(1\.[0-3]\.[0-9]+)"'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L