🇰🇷 한글 설명
Ahsay AhsayCBS 9.15.2.69 이하 및 10.3.4.44 이하 버전에서 발견된 취약점입니다. /rps/api/json/UpdateReceivers.do 파일의 Replication Receiver 컴포넌트에서 random 인자를 조작하면 OS 명령어 주입이 발생할 수 있으며, 원격에서 공격이 가능합니다. 초기 패치가 취약점을 완전히 해결하지 못해 CVE 항목이 갱신되었습니다.
💡 쉬운 설명
공격자가 원격에서 서버에 명령어를 몰래 실행할 수 있는 심각한 보안 결함입니다. 공개된 공격 코드가 존재하므로 즉시 업데이트가 필요합니다.
🇺🇸 원문 (English)
A flaw has been found in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This vulnerability affects unknown code of the file /rps/api/json/UpdateReceivers.do of the component Replication Receiver. Executing a manipulation of the argument random can lead to os command injection. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to resolve this issue. Upgrading the affected component is advised. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.
📍 영향받는 시스템
Ahsay AhsayCBS 9.15.2.69 이하 및 10.3.4.44 이하 버전
⚔️ 공격 벡터
원격에서 /rps/api/json/UpdateReceivers.do 요청의 random 인자에 OS 명령어를 주입하여 실행
🛡️ 대응 방법
AhsayCBS를 9.15.2.70 또는 10.3.4.45 이상으로 업그레이드
🔧 검증 코드
출력된 버전 정보가 9.15.2.70 또는 10.3.4.45 미만이면 취약한 것이며, 이상이면 패치가 적용된 상태입니다.
grep -ri 'version' /usr/local/cbs/ 2>/dev/null | grep -iE 'ahsay|cbs' | head -n 5
🇰🇷 KISA(한국인터넷진흥원) 보안 권고
이 CVE에 대한 한국 공식 권고 (1건)
Ahsay 제품 보안 업데이트 권고
P4
📅 2026-10-21 · sec_notice
AhsayCBS 제품에서 인증 미흡 및 OS 커맨드 인젝션 취약점이 발견되었습니다. 해당 제품의 구버전을 사용하는 사용자는 공격자의 권한 탈취 및 명령 실행을 방지하기 위해 최신 버전으로 업데이트해야 합니다.