🔍 CVE-2026-105612

3.5
CVSS Score
LOW
2026-10-28
2026-10-29 15:29
✅ 완료

🇰🇷 한글 설명

PostgreSQL Anonymizer에는 데이터를 수정하는 CTE(Common Table Expression)를 이용해 마스킹된 역할(role)의 읽기 전용 제한을 우회할 수 있는 취약점이 있습니다. 이 문제는 PostgreSQL Anonymizer 3.3.0 이상 버전에서 해결되었습니다.

💡 쉬운 설명

익명화(마스킹) 기능이 적용된 데이터베이스 사용자가 읽기 전용 권한을 벗어나 데이터를 수정할 수 있는 문제입니다. 제한된 사용자가 원래 허용되지 않은 변경 작업을 할 수 있으므로 버전을 업데이트하는 것이 안전합니다.

🇺🇸 원문 (English)

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

📍 영향받는 시스템

PostgreSQL Anonymizer 3.3.0 미만 버전을 사용하는 PostgreSQL 데이터베이스 환경

⚔️ 공격 벡터

마스킹된 권한을 가진 데이터베이스 사용자가 데이터 수정 기능이 포함된 CTE 쿼리를 실행하여 읽기 전용 제한을 우회

🛡️ 대응 방법

PostgreSQL Anonymizer를 3.3.0 이상 버전으로 업그레이드

🔧 검증 코드

출력된 버전이 3.3.0 이상이면 패치가 적용된 것이고, 3.3.0 미만이거나 결과가 없으면 취약하거나 확장이 설치되지 않은 상태입니다.

Shell / Script
psql -U postgres -d postgres -tAc "SELECT extversion FROM pg_extension WHERE extname='anon';" 2>/dev/null

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N

💻 영향받는 소프트웨어

PostgreSQL