🔍 CVE-2026-105619

4.8
CVSS Score
MEDIUM
2026-10-28
2026-10-29 15:29
✅ 완료

🇰🇷 한글 설명

PostgreSQL Anonymizer는 security_invoker 뷰를 통해 접근한 데이터에 마스킹을 적용하지 않습니다. 이 문제는 PostgreSQL Anonymizer 3.3.0 이상 버전에서 해결되었습니다.

💡 쉬운 설명

데이터를 가려서 보호하는 PostgreSQL 확장 기능에 결함이 있어, 특정 뷰를 통해 조회하면 원본 개인정보가 가려지지 않고 노출될 수 있습니다. 최신 버전으로 업데이트하면 이 문제가 해결됩니다.

🇺🇸 원문 (English)

PostgreSQL Anonymizer doesn't mask data accessed thru a security_invoker view. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions.

📍 영향받는 시스템

PostgreSQL Anonymizer 3.3.0 미만 버전 (security_invoker 뷰 사용 환경)

⚔️ 공격 벡터

권한이 있는 사용자가 security_invoker 뷰를 통해 조회하여 마스킹되어야 할 원본 데이터를 확인

🛡️ 대응 방법

PostgreSQL Anonymizer를 3.3.0 이상 버전으로 업데이트

🔧 검증 코드

출력된 버전이 3.3.0 이상이면 패치 적용된 상태이며, 결과가 없거나 3.3.0 미만이면 업데이트가 필요합니다.

Shell / Script
psql -U postgres -d your_database -tAc "SELECT extversion FROM pg_extension WHERE extname='anon';"

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N

💻 영향받는 소프트웨어

PostgreSQL