🇰🇷 한글 설명
Node.js 기반 CMS인 Ghost의 1.20.0부터 6.64.0 버전 사이에서 테마 번역 파일을 로드하는 방식에 취약점이 발견되었습니다. 인증된 관리자가 테마 디렉토리 외부의 JSON 파일을 읽을 수 있어 서버 설정 비밀 정보가 노출될 위험이 있습니다.
💡 쉬운 설명
관리자 권한을 가진 사용자가 시스템의 중요한 설정 파일들을 몰래 훔쳐볼 수 있는 문제입니다. 이로 인해 서버의 비밀번호나 중요한 설정 정보가 유출될 수 있습니다.
🇺🇸 원문 (English)
Ghost is a Node.js content management system. From 1.20.0 until 6.64.0, a vulnerability in how Ghost loads theme translation files allowed an authenticated Administrator to read JSON files outside of the active theme's directory, potentially exposing server configuration secrets. This issue is fixed in version 6.64.0.
📍 영향받는 시스템
Ghost CMS version 1.20.0 ~ 6.64.0
⚔️ 공격 벡터
인증된 관리자 권한을 이용한 경로 조작을 통한 외부 JSON 파일 읽기
🛡️ 대응 방법
Ghost CMS를 최신 버전인 6.64.0 이상으로 업데이트하십시오.
🔧 검증 코드
명령어 결과에 버전 번호가 출력되면 취약한 버전이 설치되어 있는 상태입니다.
npm list -g ghost --depth=0 | grep -E 'ghost@([1-6]\.[0-9]{2}\.[0-9]{2}|[2-6]\.[0-9]{2}\.[0-9]{2})' | grep -v '6.64.0'
📊 CVSS Vector String
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
💻 영향받는 소프트웨어
Multi-Domain Security Management Server