🔍 CVE-2026-105858

8.1
CVSS Score
HIGH
2026-10-06
2026-10-15 00:11
✅ 완료

🇰🇷 한글 설명

Payload CMS의 특정 버전에서 로컬 인증이 활성화되어 있고 초기 사용자가 생성되지 않은 상태일 때, 공개된 첫 등록 작업에 조작된 요청을 보내 원격 코드 실행이 가능합니다. 이 취약점은 3.90.0 미만 버전 및 4.0.0-canary.34 미만 카나리 버전에서 발생합니다.

💡 쉬운 설명

웹사이트 관리 도구의 초기 설정 단계에서 보안 허점이 발견되어, 해커가 원격으로 명령을 내릴 수 있는 위험이 있습니다. 관리자 계정이 만들어지기 전 단계에서 공격이 이루어질 수 있습니다.

🇺🇸 원문 (English)

Payload is a free and open source headless content management system. In versions before 3.90.0 and canary versions before 4.0.0-canary.34, a crafted request to the public first-register operation can execute code remotely when local authentication is enabled and no initial user has been created. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.

📍 영향받는 시스템

Payload CMS < 3.90.0 및 < 4.0.0-canary.34

⚔️ 공격 벡터

공개된 첫 사용자 등록(first-register) API에 조작된 요청을 전송하여 원격 코드 실행(RCE)

🛡️ 대응 방법

Payload CMS를 3.90.0 또는 4.0.0-canary.34 이상의 버전으로 업데이트하십시오.

🔧 검증 코드

명령어 결과에 취약한 버전 범위가 출력되면 업데이트가 필요한 상태입니다.

Shell / Script
npm list payload --depth=0 | grep -E 'payload@(3\.[0-8][0-9]|4\.0\.0-canary\.[0-3][4-9])'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Magento Open Source