🔍 CVE-2026-107806

7.2
CVSS Score
HIGH
2026-10-09
2026-10-20 20:44
✅ 완료

🇰🇷 한글 설명

Nginx UI 2.3.8부터 2.5.0 버전 사이에서 인증된 관리자가 조작된 백업 키와 매니페스트를 사용하여 /api/restore 엔드포인트로 악성 설정을 주입할 수 있는 취약점이 발견되었습니다. 공격자는 이를 통해 app.ini 파일을 교체하고 TestConfigCmd와 같은 보호된 명령 설정을 변경하여 임의의 명령을 실행할 수 있습니다.

💡 쉬운 설명

관리자 권한을 가진 사용자가 가짜 백업 파일을 업로드하여 웹 서버의 설정 파일을 마음대로 바꿀 수 있는 문제입니다. 이를 통해 해커가 서버에 몰래 명령을 내려 시스템을 장악하거나 정보를 빼낼 수 있습니다.

🇺🇸 원문 (English)

Nginx UI is a web user interface for the Nginx web server. From 2.3.8 until 2.5.0, an authenticated administrator with an active secure session can submit attacker-controlled portable backup key material and a matching manifest to POST /api/restore. The restore flow trusts the supplied key, decrypts attacker-controlled contents, and replaces the live app.ini, including protected nginx command settings such as TestConfigCmd. Triggering POST /api/nginx/test then executes the restored command in the Nginx UI runtime context, affecting confidentiality, integrity, and availability. This issue is fixed in version 2.5.0.

📍 영향받는 시스템

Nginx UI 버전 2.3.8 ~ 2.5.0

⚔️ 공격 벡터

인증된 관리자 세션을 이용한 /api/restore API 호출 및 조작된 백업 데이터 전송

🛡️ 대응 방법

Nginx UI를 최신 버전인 2.5.0 이상으로 업데이트하십시오.

🔧 검증 코드

명령어 실행 결과에 취약한 버전 범위(2.3.8~2.5.0)가 나타나면 해당 시스템은 취약한 상태입니다.

Shell / Script
curl -s http://<target_ip>/version | grep -E '2\.(3\.[8-9]|4\.[0-9]|5\.0)'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Nginx