🔍 CVE-2026-107809

8.8
CVSS Score
HIGH
2026-10-09
2026-10-20 15:15
✅ 완료

🇰🇷 한글 설명

Nginx UI 2.0.0부터 2.5.0 버전 사이에서 CSRF 보호 미흡으로 인해 발생하는 취약점입니다. 공격자는 로그인된 관리자의 브라우저를 통해 인증된 상태로 Nginx 설정을 변경하거나 재시작하는 등의 관리 작업을 수행할 수 있습니다.

💡 쉬운 설명

로그인된 관리자가 악성 사이트를 방문하기만 해도, 관리자 몰래 Nginx 서버의 설정을 바꾸거나 조작할 수 있는 보안 결함입니다. 관리자 권한을 탈취하여 서버 운영을 방해할 수 있습니다.

🇺🇸 원문 (English)

Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, AuthRequired accepts a browser-managed token cookie as an API credential after the front end stores the JWT in that cookie. Because management endpoints do not universally require a CSRF token or perform Origin or Referer validation, a remote attacker can induce a logged-in administrator's browser to submit authenticated cross-site state-changing requests, including POST /api/configs. The attack requires an administrator account without OTP/Passkey or a target endpoint that does not require secure-session proof. The attacker cannot read the cross-origin response but can modify Nginx configuration, trigger reloads, or invoke other management operations reachable with the victim's session. This issue is fixed in version 2.5.0.

📍 영향받는 시스템

Nginx UI 버전 2.0.0 ~ 2.5.0

⚔️ 공격 벡터

CSRF(사이트 간 요청 위조)를 이용한 관리자 세션 악용

🛡️ 대응 방법

Nginx UI를 최신 버전인 2.5.0 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 정보가 2.0.0에서 2.5.0 사이라면 해당 취약점에 노출된 상태입니다.

Shell / Script
curl -s http://<target_ip>/api/version | grep -E '2\.[0-5]'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Log Server