🇰🇷 한글 설명
Nginx UI 2.0.0부터 2.5.0 버전 사이에서 api/cluster 라우터가 보안 세션 검증 없이 노드 및 네임스페이스 변경 작업을 허용하는 취약점이 발견되었습니다. OTP를 사용하는 인증된 사용자라도 탈취된 JWT를 보유하고 있다면 추가적인 2단계 인증 없이 노드 관리 및 Nginx 재시작 등의 민감한 작업을 수행할 수 있습니다.
💡 쉬운 설명
로그인 정보(JWT)를 훔친 공격자가 추가적인 본인 확인 절차 없이 서버의 설정을 바꾸거나 재시작할 수 있는 보안 결함입니다. 이로 인해 관리자 권한을 가진 것처럼 서버를 마음대로 조작할 위험이 있습니다.
🇺🇸 원문 (English)
Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, the api/cluster router exposes node and namespace mutation operations and cluster-wide Nginx reload or restart operations with AuthRequired but without RequireSecureSession. An authenticated OTP-enabled user possessing a stolen or persisted JWT can therefore perform node CRUD, read or replace node credentials, change namespaces, and invoke nodes/reload_nginx or nodes/restart_nginx without a fresh second-factor step-up. This issue is an incomplete fix for CVE-2026-84315 and is fixed in version 2.5.0.
📍 영향받는 시스템
Nginx UI version 2.0.0 ~ 2.5.0
⚔️ 공격 벡터
탈취된 JWT 토큰을 이용한 인증 우회 및 API 호출을 통한 권한 남용
🛡️ 대응 방법
Nginx UI를 최신 보안 패치가 적용된 버전 2.5.0 이상으로 업데이트하십시오.
🔧 검증 코드
출력 결과에 2.0.0에서 2.4.x 사이의 버전이 포함되어 있으면 취약한 상태입니다.
curl -s http://<target-ip>/version | grep -E '2\.[0-4]\.' || echo 'Not vulnerable or version not found'