🇰🇷 한글 설명
Apache Traffic Server에서 잘못된 패딩이 포함된 HTTP/2 DATA 프레임을 사용하여 HTTP/1.1 오리진의 워커 풀을 고갈시킬 수 있는 취약점입니다. 이로 인해 서비스 거부(DoS) 상태가 발생할 수 있습니다.
💡 쉬운 설명
공격자가 특수하게 조작된 데이터를 보내 서버의 작업 처리 능력을 모두 소모하게 만드는 공격입니다. 이로 인해 정상적인 사용자가 웹사이트에 접속하지 못할 수 있습니다.
🇺🇸 원문 (English)
Apache Traffic Server can be used to exhaust an HTTP/1.1 origin's worker pool via a malformed padded HTTP/2 DATA frame.
This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.15, from 10.0.0 through 10.1.4, 10.2.0.
Users are recommended to upgrade to version 9.2.16, 10.1.5, or 10.2.1, which fix the issue.
📍 영향받는 시스템
Apache Traffic Server 8.0.0-8.1.11, 9.0.0-9.2.15, 10.0.0-10.1.4, 10.2.0
⚔️ 공격 벡터
조작된 HTTP/2 DATA 프레임을 전송하여 오리진 서버의 워커 풀 자원을 고갈시킴
🛡️ 대응 방법
Apache Traffic Server를 버전 9.2.16, 10.1.5 또는 10.2.1 이상으로 업그레이드하십시오.
🔧 검증 코드
출력된 버전 번호가 취약한 버전 범위(8.x, 9.x, 10.x 일부)에 포함되는지 확인하십시오.
apache2-traffic-server --version 2>/dev/null || httpd -v 2>/dev/null | grep -i 'Apache Traffic Server'