🔍 CVE-2026-112954

5.3
CVSS Score
MEDIUM
2026-10-20
2026-10-23 02:16
✅ 완료

🇰🇷 한글 설명

ApostropheCMS 4.34.0 미만 버전에서 공용 REST API의 publicApiProjection 설정 오류로 인해 검색 및 정렬 기능을 이용한 정보 유출 취약점이 존재합니다. 공격자는 필드 데이터 자체를 직접 가져올 수는 없으나, 검색 결과의 포함 여부나 정렬 순서를 통해 숨겨진 필드 값을 추론할 수 있습니다.

💡 쉬운 설명

데이터를 숨겨놓았더라도 검색 결과가 어떻게 바뀌는지 관찰함으로써 숨겨진 내용을 눈치챌 수 있는 보안 허점입니다. 마치 상자 안의 물건을 직접 보지는 못해도, 상자를 흔들었을 때 나는 소리로 내용물을 맞히는 것과 비슷합니다.

🇺🇸 원문 (English)

ApostropheCMS is an open-source Node.js content management system. Prior to 4.34.0, a public REST API type that uses publicApiProjection can expose excluded searchable or sortable field information through search membership and sort ordering oracles. Returned fields remain filtered by the projection, so the issue permits targeted inference about hidden values rather than an unrestricted field dump. This issue is fixed in version 4.34.0.

📍 영향받는 시스템

ApostropheCMS 4.34.0 미만 버전

⚔️ 공격 벡터

REST API의 검색 멤버십 및 정렬 오라클을 이용한 데이터 추론 공격

🛡️ 대응 방법

ApostropheCMS를 4.34.0 이상 버전으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 번호가 4.34.0보다 낮으면 취약한 상태이며, 4.34.0 이상이면 안전합니다.

Shell / Script
npm list apostrophe-cms | grep -E 'apostrophe-cms@([0-9]+\.[0-9]+\.[0-9]+)'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

💻 영향받는 소프트웨어

Node.js