🔍 CVE-2026-113661

5.4
CVSS Score
MEDIUM
2026-10-20
2026-10-21 16:17
✅ 완료

🇰🇷 한글 설명

ApostropheCMS에서 사용하는 sanitize-html 라이브러리 2.18.0 미만 버전에서 발생하는 취약점입니다. 특정 설정에서 meta refresh 요소의 http-equiv 및 content 속성을 허용할 경우, 내부에 포함된 악성 스크립트나 리다이렉션 목적지를 제대로 제거하지 못할 수 있습니다.

💡 쉬운 설명

웹사이트의 HTML 코드를 깨끗하게 청소해주는 도구에 구멍이 있어, 나쁜 코드가 숨어 들어올 수 있습니다. 이 구멍을 통해 공격자가 사용자를 가짜 사이트로 보내거나 악성 프로그램을 실행하게 만들 수 있습니다.

🇺🇸 원문 (English)

ApostropheCMS is an open-source Node.js content management system, and sanitize-html provides a simple HTML sanitizer with a clear API. Prior to sanitize-html 2.18.0, a non-default configuration that allows meta refresh elements and their http-equiv and content attributes can retain unsafe script or redirect destinations embedded in the refresh content value. This issue is fixed in sanitize-html 2.18.0.

📍 영향받는 시스템

sanitize-html 2.18.0 미만 버전이 포함된 ApostropheCMS 환경

⚔️ 공격 벡터

HTML sanitizer 설정에서 meta refresh 요소를 허용하도록 구성된 경우, 악성 스크립트가 포함된 meta 태그를 삽입하여 공격

🛡️ 대응 방법

sanitize-html 라이브러리를 2.18.0 이상 버전으로 업데이트

🔧 검증 코드

명령어 결과에 sanitize-html 버전이 2.18.0 미만으로 표시되면 취약한 상태입니다.

Shell / Script
npm list sanitize-html | grep -E 'sanitize-html@([0-1]\.|2\.(0|1|1[0-7]))'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

💻 영향받는 소프트웨어

Node.js