🔍 CVE-2026-114422

7.5
CVSS Score
HIGH
2026-10-30
2026-10-30 17:49
✅ 완료

🇰🇷 한글 설명

Enable Media Replace WordPress 플러그인 4.2.3 이전 버전은 미디어 교체 및 링크 갱신 과정에서 저장된 메타데이터를 역직렬화할 때 허용 클래스를 제한하지 않습니다. 이로 인해 인증되지 않은 사용자가 PHP 객체를 주입할 수 있으며, 업로드 권한을 가진 사용자가 미디어 교체를 수행할 때 해당 객체가 생성되어 PHP 객체 주입 및 로컬 파일 포함(LFI)이 발생합니다. 서버에 공격자가 영향을 줄 수 있는 PHP 또는 HTML 파일이 존재하면 원격 코드 실행(RCE)으로 확대될 수 있습니다. 이 취약점은 CVE-2023-4643의 회귀 취약점입니다.

💡 쉬운 설명

워드프레스 미디어 교체 기능의 보안 결함으로, 로그인하지 않은 공격자도 악성 데이터를 심을 수 있습니다. 관리자가 미디어를 교체할 때 이 데이터가 실행되어 서버의 파일이 노출되거나 원격으로 명령이 실행될 수 있습니다.

🇺🇸 원문 (English)

The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when deserializing stored metadata during its media replace-and-update-links routine, allowing unauthenticated users to inject a PHP object that is instantiated when a user with upload access performs a routine media replacement, resulting in PHP Object Injection and local file inclusion of existing PHP/HTML files, which can be escalated to remote code execution where an attacker-influenced PHP or HTML file is present on the server. This is a regression of CVE-2023-4643, which was fixed in 4.1.3 and reintroduced in 4.1.4.

📍 영향받는 시스템

Enable Media Replace WordPress 플러그인 4.2.3 미만 버전 (4.1.4 포함 회귀 버전)

⚔️ 공격 벡터

인증되지 않은 공격자가 조작된 직렬화 데이터를 주입한 뒤, 업로드 권한이 있는 사용자가 미디어 교체를 수행하면 PHP 객체 주입 및 LFI/RCE가 발생

🛡️ 대응 방법

Enable Media Replace 플러그인을 4.2.3 이상으로 즉시 업데이트하고, 업데이트 전까지 플러그인을 비활성화하며 서버의 의심스러운 PHP/HTML 파일을 점검

🔧 검증 코드

출력된 버전이 4.2.3 미만이면 취약한 것이며, 4.2.3 이상이면 패치가 적용된 것입니다. 명령이 아무 결과도 내지 않으면 플러그인이 설치되지 않은 것입니다.

Shell / Script
wp plugin get enable-media-replace --field=version 2>/dev/null || grep -h "Version:" wp-content/plugins/enable-media-replace/enable-media-replace.php 2>/dev/null

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP