🔍 CVE-2026-12241

5.4
CVSS Score
MEDIUM
2026-10-01
2026-10-03 16:16
✅ 완료

🇰🇷 한글 설명

WordPress용 Advanced Woo Labels 플러그인 2.51 이하 버전에서 권한 확인 미흡으로 인해 데이터가 무단 수정될 수 있는 취약점이 발견되었습니다. 이를 통해 기여자(Contributor) 이상의 권한을 가진 인증된 공격자가 적절한 이스케이프 처리 없이 렌더링되는 AWS 라벨을 생성할 수 있습니다.

💡 쉬운 설명

웹사이트 관리 권한이 낮은 사용자도 제품에 표시되는 라벨 내용을 마음대로 바꿀 수 있는 보안 약점이 있습니다. 공격자가 이 기능을 악용해 웹사이트에 해로운 코드를 삽입할 위험이 있습니다.

🇺🇸 원문 (English)

The Advanced Woo Labels – Product Labels & Badges for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to an improperly secure capability check on the 'save_meta_boxes' function in all versions up to, and including, 2.51. This makes it possible for authenticated attackers, with Contributor-level access and above, to create AWS labels that are rendered without proper escaping. The vulnerability was partially patched in version 2.46.

📍 영향받는 시스템

Advanced Woo Labels – Product Labels & Badges for WooCommerce (v2.51 이하 모든 버전)

⚔️ 공격 벡터

기여자(Contributor) 이상의 권한을 가진 인증된 사용자가 'save_meta_boxes' 함수를 악용하여 조작된 라벨 데이터를 저장

🛡️ 대응 방법

플러그인을 최신 버전으로 업데이트하여 권한 확인 및 데이터 이스케이프 처리가 적용된 패치를 적용하십시오.

🔧 검증 코드

출력된 버전 번호가 2.51보다 높은지 확인하십시오.

Shell / Script
wp plugin list --status=active | grep -i 'advanced-woo-labels' && wp plugin list --format=json | jq '.[] | select(.name=="advanced-woo-labels") | .version'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

💻 영향받는 소프트웨어

WordPress