🔍 CVE-2026-14265

7.5
CVSS Score
HIGH
2026-07-01
2026-10-25 16:10
✅ 완료

🇰🇷 한글 설명

AWS Advanced JDBC Wrapper 3.3.0에서 4.0.0 버전 사이의 RemoteQueryCachePlugin에서 신뢰할 수 없는 데이터의 역직렬화 취약점이 발견되었습니다. 공유 캐시 인프라에 쓰기 권한이 있는 공격자가 조작된 Java 객체를 통해 애플리케이션 서버에서 임의의 코드를 실행할 수 있습니다.

💡 쉬운 설명

캐시 저장소에 저장된 데이터를 읽어올 때 검증 없이 실행하여 해커가 서버를 조종할 수 있는 문제입니다. 해커가 캐시 데이터에 악성 코드를 심어두면 서버가 이를 실행하게 됩니다.

🇺🇸 원문 (English)

Deserialization of untrusted data in the RemoteQueryCachePlugin in Amazon Web Services AWS Advanced JDBC Wrapper 3.3.0 through 4.0.0 might allow an actor with write access to the shared cache infrastructure to execute arbitrary code on application servers that read cached query results via a crafted serialized Java object. The RemoteQueryCachePlugin uses ObjectInputStream without class filtering when deserializing cached query results from Redis or Valkey, enabling gadget chain execution when cache entries are poisoned. We recommend upgrading to AWS Advanced JDBC Wrapper version 4.0.1 or later.

📍 영향받는 시스템

AWS Advanced JDBC Wrapper 3.3.0 ~ 4.0.0

⚔️ 공격 벡터

Redis 또는 Valkey 캐시 인프라에 조작된 직렬화된 Java 객체를 주입하여 실행

🛡️ 대응 방법

AWS Advanced JDBC Wrapper 버전을 4.0.1 이상으로 업그레이드

🔧 검증 코드

출력된 결과에서 aws-advanced-jdbc-wrapper의 버전이 4.0.1 미만인지 확인

Shell / Script
mvn dependency:list | grep 'aws-advanced-jdbc-wrapper'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

IBM WebSphere Application Server