🔍 CVE-2026-14943

7.5
CVSS Score
HIGH
2026-08-07
2026-08-26 16:31
✅ 완료

🇰🇷 한글 설명

Password Protected — Lock Entire Site, Pages, Posts, Categories, and Partial Content WordPress 플러그인 2.8.4 미만 버전에서 특정 옵션 활성화 시 REST API 접근 제한이 이루어지지 않는 취약점이 발견되었습니다. 이로 인해 인증되지 않은 방문자가 사이트 전체의 비밀번호 보호를 우회하여 보호된 콘텐츠와 계정 식별자를 읽을 수 있습니다. 이는 과거에 수정되었던 CVE-2024-0437 문제가 2.6.8 버전에서 다시 발생한 회귀 취약점입니다.

💡 쉬운 설명

비밀번호로 사이트를 잠가두었음에도 불구하고, 특수한 통로(REST API)를 통해 누구나 잠긴 내용을 몰래 볼 수 있는 보안 구멍이 생겼습니다. 이로 인해 보호되어야 할 글이나 사용자 정보가 외부에 노출될 위험이 있습니다.

🇺🇸 원문 (English)

The Password Protected — Lock Entire Site, Pages, Posts, Categories, and Partial Content WordPress plugin before 2.8.4 does not restrict REST API access to authenticated users when a specific option is enabled, allowing unauthenticated visitors to bypass the sitewide password gate and read otherwise-protected content and account identifiers via the REST API. This re-introduces a previously-fixed issue (CVE-2024-0437), which was patched in 2.6.7 and regressed in 2.6.8.

📍 영향받는 시스템

WordPress plugin 'Password Protected — Lock Entire Site, Pages, Posts, Categories, and Partial Content' version < 2.8.4

⚔️ 공격 벡터

인증되지 않은 공격자가 REST API 엔드포인트를 호출하여 보호된 콘텐츠 및 계정 정보에 접근

🛡️ 대응 방법

해당 플러그인을 최신 버전인 2.8.4 이상으로 즉시 업데이트하십시오.

🔧 검증 코드

출력된 플러그인 버전이 2.8.4 미만인지 확인하십시오.

Shell / Script
wp plugin list --status=active | grep -i 'password-protected' && wp plugin list --format=json | jq '.[] | select(.name=="password-protected") | .version'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

💻 영향받는 소프트웨어

WordPress