🔍 CVE-2026-15290

7.5
CVSS Score
HIGH
2026-07-10
2026-07-10 17:16
✅ 완료

🇰🇷 한글 설명

WordPress의 Ultimate Member 플러그인 2.10.1 이하 버전에서 검색 파라미터를 통한 Blind SQL Injection 취약점이 발견되었습니다. 사용자 입력값에 대한 검증 및 SQL 쿼리 준비 과정이 미흡하여, 인증되지 않은 공격자가 데이터베이스에서 민감한 정보를 추출할 수 있습니다.

💡 쉬운 설명

웹사이트의 검색창에 특수한 명령어를 입력하여 데이터베이스를 몰래 조작할 수 있는 보안 약점입니다. 이를 통해 해커가 회원 정보와 같은 중요한 데이터를 훔쳐갈 수 있습니다.

🇺🇸 원문 (English)

The Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin plugin for WordPress is vulnerable to blind SQL Injection via the search parameter in all versions up to, and including, 2.10.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This vulnerability was partially patched in version 2.9.2 when initially addressing CVE-2025-0308.

📍 영향받는 시스템

Ultimate Member WordPress Plugin (버전 2.10.1 및 그 이하 모든 버전)

⚔️ 공격 벡터

인증되지 않은 공격자가 검색(search) 파라미터에 악의적인 SQL 구문을 삽입하여 공격

🛡️ 대응 방법

Ultimate Member 플러그인을 최신 보안 패치가 적용된 버전으로 즉시 업데이트하십시오.

🔧 검증 코드

출력된 결과에서 ultimate-member의 버전이 2.10.1 이하인지 확인하십시오.

Shell / Script
wp-cli plugin list --allow-root | grep -E 'ultimate-member'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

💻 영향받는 소프트웨어

Spring Data REST