🔍 CVE-2026-15810

0.0
CVSS Score
UNKNOWN
2026-07-24
2026-10-24 13:10
✅ 완료

🇰🇷 한글 설명

Google Cloud Looker의 여러 버전(25.6.103 이전 등)에서 Looker 호스팅 및 자체 호스팅 환경 모두에 크로스 사이트 스크립팅(XSS) 취약점이 존재합니다. 악성 조작된 URL을 통해 임의의 자바스크립트가 실행되어 관리자 계정이 탈취될 수 있습니다. Looker 호스팅 인스턴스는 이미 완화되었으며, 자체 호스팅 인스턴스는 패치된 버전으로 업그레이드해야 합니다.

💡 쉬운 설명

공격자가 교묘하게 만든 링크를 클릭하게 하면, 그 안에 숨은 악성 코드가 실행되어 관리자 계정을 빼앗길 수 있습니다. 클라우드 서비스는 이미 보호되었고, 직접 운영하는 서버만 업데이트하면 됩니다.

🇺🇸 원문 (English)

A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.

📍 영향받는 시스템

Google Cloud Looker 25.6.103 미만, 25.12.65 미만, 25.18.68 미만, 26.0.66 미만, 26.2.47 미만, 26.4.36 미만, 26.6.28 미만, 26.8.7 미만의 자체 호스팅(Self-hosted) 인스턴스

⚔️ 공격 벡터

공격자가 악성 스크립트가 포함된 조작된 URL을 관리자에게 전달하여 클릭하게 한 뒤, 세션 정보나 관리자 권한을 탈취

🛡️ 대응 방법

자체 호스팅 Looker를 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, 26.8.7+ 중 해당 브랜치의 패치 버전으로 업그레이드

🔧 검증 코드

응답 헤더의 Looker 버전이 해당 브랜치의 패치 버전 이상이면 조치 완료이고, 미만이면 아직 취약한 상태이므로 업그레이드가 필요합니다. (헤더가 노출되지 않는 경우 Looker 관리 콘솔의 버전 정보를 확인하세요)

Shell / Script
curl -sI https://YOUR_LOOKER_HOST/ | grep -i 'x-looker-version'

💻 영향받는 소프트웨어

Oracle Java SE