🔍 CVE-2026-22265

7.5
CVSS Score
HIGH
2026-01-15
2026-06-17 10:19
✅ 완료

🇰🇷 한글 설명

Roxy-WI는 HAProxy, Nginx, Apache, Keepalived 서버를 관리하는 웹 인터페이스입니다. 8.2.8.2 이전 버전에서는 로그 조회 기능에 명령어 주입 취약점이 존재하여, 인증된 사용자가 임의의 시스템 명령을 실행할 수 있습니다. 취약점은 app/modules/roxywi/logs.py 87행에서 grep 파라미터가 한 번은 필터링된 상태로, 한 번은 원본 그대로 사용되는 데서 발생하며, 8.2.8.2 버전에서 수정되었습니다.

💡 쉬운 설명

로그를 보는 기능에 입력값 검증이 빠져 있어, 로그인한 사용자가 서버에서 원하는 명령을 몰래 실행할 수 있습니다. 이 문제는 최신 버전인 8.2.8.2 이상으로 업데이트하면 해결됩니다.

🇺🇸 원문 (English)

Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. Prior to 8.2.8.2, command injection vulnerability exists in the log viewing functionality that allows authenticated users to execute arbitrary system commands. The vulnerability is in app/modules/roxywi/logs.py line 87, where the grep parameter is used twice - once sanitized and once raw. This vulnerability is fixed in 8.2.8.2.

📍 영향받는 시스템

Roxy-WI 8.2.8.2 미만 버전

⚔️ 공격 벡터

인증된 사용자가 로그 조회 기능의 grep 파라미터에 셸 명령어를 삽입하여 임의 명령을 실행

🛡️ 대응 방법

Roxy-WI를 8.2.8.2 이상 버전으로 업데이트

🔧 검증 코드

출력된 87행 코드에서 grep 파라미터가 sanitize 없이 셸 명령에 직접 사용되면 취약한 버전이며, 수정 버전은 입력값 검증 코드가 적용되어 있습니다.

Shell / Script
grep -rn 'grep' /opt/roxy-wi/app/modules/roxywi/logs.py 2>/dev/null | head -5

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Nginx