🔍 CVE-2026-22428

8.1
CVSS Score
HIGH
2026-03-05
2026-04-22 21:26
✅ 완료

🇰🇷 한글 설명

AncoraThemes Tooth Fairy 테마에서 PHP include/require 문에 대한 부적절한 파일명 제어로 인해 로컬 파일 포함(LFI) 취약점이 발생합니다. 공격자는 악의적인 파일 경로를 입력하여 서버의 임의 파일을 포함시킬 수 있으며, 이를 통해 민감한 정보 유출이나 코드 실행이 가능합니다.

💡 쉬운 설명

WordPress 테마인 Tooth Fairy에 파일 접근 제어 결함이 있어서, 해커가 서버 내 임의의 파일을 읽을 수 있습니다. 버전 1.16 이하를 사용 중인 경우 즉시 업데이트가 필요합니다.

🇺🇸 원문 (English)

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in AncoraThemes Tooth Fairy tooth-fairy allows PHP Local File Inclusion.This issue affects Tooth Fairy: from n/a through <= 1.16.

📍 영향받는 시스템

AncoraThemes Tooth Fairy theme version <= 1.16

⚔️ 공격 벡터

Attacker crafts malicious input in include/require parameters to access arbitrary files on the server through path traversal or direct file inclusion

🛡️ 대응 방법

Update Tooth Fairy theme to version > 1.16 or apply official security patches from AncoraThemes

🔧 검증 코드

style.css의 Version 필드나 WordPress API에서 테마 버전을 확인하여 1.16 이하이면 업데이트 필요

Shell / Script
grep -r 'Version:' ~/.wp-plugins/themes/tooth-fairy/style.css 2>/dev/null || curl -s https://api.wordpress.org/themes/info/1.0/tooth-fairy.json 2>/dev/null | grep -oP '"version":\s*"\K[^"]+' || echo 'Theme not found'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP