🔍 CVE-2026-22594

8.1
CVSS Score
HIGH
2026-01-10
2026-06-17 10:20
✅ 완료

🇰🇷 한글 설명

Ghost는 Node.js 기반의 콘텐츠 관리 시스템입니다. 5.105.0부터 5.130.5 및 6.0.0부터 6.10.3 버전에서 이중 인증(2FA) 메커니즘의 취약점으로 인해 스태프 사용자가 이메일 2FA를 건너뛸 수 있습니다. 이 문제는 5.130.6 및 6.11.0 버전에서 패치되었습니다.

💡 쉬운 설명

Ghost 콘텐츠 관리 시스템의 이중 인증 메커니즘에 취약점이 있어 스태프 사용자가 이메일 인증을 무시할 수 있습니다. 이는 높은 심각도로 평가됩니다. 최신 버전으로 업데이트하여 취약점을 해결할 수 있습니다.

🇺🇸 원문 (English)

Ghost is a Node.js content management system. In versions 5.105.0 through 5.130.5 and 6.0.0 through 6.10.3, a vulnerability in Ghost's 2FA mechanism allows staff users to skip email 2FA. This issue has been patched in versions 5.130.6 and 6.11.0.

📍 영향받는 시스템

Ghost 5.105.0-5.130.5, 6.0.0-6.10.3

⚔️ 공격 벡터

이중 인증 메커니즘의 취약점을 이용한 스태프 사용자 계정 접근

🛡️ 대응 방법

Ghost를 5.130.6 또는 6.11.0 버전으로 업데이트하여 취약점을 해결합니다.

🔧 검증 코드

로컬에서 npm을 사용하여 설치된 Ghost 버전을 확인합니다. verification_code를 실행하기 전에 npm이 설치되어 있어야 하며, Ghost가 로컬에서 설치되어 있어야 합니다. 코드를 실행하면 현재 설치된 Ghost 버전을 확인하여 취약한 버전인지 여부를 판단합니다.

Shell / Script
import subprocess
result = subprocess.run(['npm', 'ls', 'ghost'], capture_output=True, text=True)
if '5.105.0' <= result.stdout.split('@')[1].split('-')[0] <= '5.130.5' or '6.0.0' <= result.stdout.split('@')[1].split('-')[0] <= '6.10.3':
    print({"result": "취약", "reason": "Ghost 버전이 취약한 범위 내에 있습니다."})
else:
    print({"result": "양호", "reason": "Ghost 버전이 안전한 범위 내에 있습니다."})

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

💻 영향받는 소프트웨어

Node.js