🔍 CVE-2026-22595

8.1
CVSS Score
HIGH
2026-01-10
2026-06-17 10:20
✅ 완료

🇰🇷 한글 설명

Ghost는 Node.js 기반의 콘텐츠 관리 시스템입니다. 5.121.0부터 5.130.5 및 6.0.0부터 6.10.3 버전까지 Staff Token 인증 처리에 취약점이 있어 Staff Session 인증을 통해만 접근이 허용된 일부 엔드포인트에 접근할 수 있었습니다. Staff Token을 통해 Admin/Owner 역할의 사용자 인증이 된 외부 시스템은 이러한 엔드포인트에 접근할 수 있었습니다. 이 문제는 5.130.6 및 6.11.0 버전에서 패치되었습니다.

💡 쉬운 설명

Ghost 콘텐츠 관리 시스템의 일부 버전에서 인증 처리에 취약점이 발견되었습니다. 이 취약점으로 인해 일부 엔드포인트에 허용되지 않은 접근이 가능해집니다. 최신 버전으로 업데이트하여 취약점을 해결할 수 있습니다.

🇺🇸 원문 (English)

Ghost is a Node.js content management system. In versions 5.121.0 through 5.130.5 and 6.0.0 through 6.10.3, a vulnerability in Ghost's handling of Staff Token authentication allowed certain endpoints to be accessed that were only intended to be accessible via Staff Session authentication. External systems that have been authenticated via Staff Tokens for Admin/Owner-role users would have had access to these endpoints. This issue has been patched in versions 5.130.6 and 6.11.0.

📍 영향받는 시스템

Ghost 5.121.0-5.130.5 및 6.0.0-6.10.3

⚔️ 공격 벡터

Staff Token을 사용한 인증 우회

🛡️ 대응 방법

Ghost를 5.130.6 또는 6.11.0 버전으로 업데이트합니다.

🔧 검증 코드

이 코드는 로컬 시스템의 Ghost 버전을 확인하여 취약점 여부를 점검합니다. Python 3.x 이상 버전에서 실행할 수 있으며, requests 라이브러리가 필요합니다. 코드를 실행하기 전에 Ghost 버전을 확인하는 URL을 수정해야 합니다.

Shell / Script
import requests
version = requests.get('https://example.com/ghost/version').json()['version']
if version in ['5.121.0', '5.122.0', '5.123.0', '5.124.0', '5.125.0', '5.126.0', '5.127.0', '5.128.0', '5.129.0', '5.130.0', '5.130.1', '5.130.2', '5.130.3', '5.130.4', '5.130.5', '6.0.0', '6.1.0', '6.2.0', '6.3.0', '6.4.0', '6.5.0', '6.6.0', '6.7.0', '6.8.0', '6.9.0', '6.10.0', '6.10.1', '6.10.2', '6.10.3']:
    print({"result": "취약", "reason": "Ghost 버전이 취약한 버전입니다."})
else:
    print({"result": "양호", "reason": "Ghost 버전이 최신 버전입니다."})

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

💻 영향받는 소프트웨어

Node.js